System requirements

Aspose.OMR for .NET is a self-contained development library that does not require additional software or third-party components to be installed.

Supported operating systems

Both x86 (where applicable) and x64 versions of the following operating systems are supported:

Desktop

  • Windows 11: Home, Pro, Pro Education, Pro for Workstations, Enterprise, and Education
  • Windows 10 version 1703: Home, Professional, Education, and Enterprise
  • Windows 8: Core, Professional, and Enterprise
  • Windows 7: Home Premium, Professional, Enterprise, Ultimate

Server

  • Windows Server 2022
  • Windows Server 2019
  • Windows Server 2016
  • Windows Server 2012
  • Windows Server 2008

Development environments

You can use Aspose.OMR for .NET with any development environment targeting the .NET platform. The library has been specifically tested with the following integrated development environments (IDEs) from Microsoft:

  • Microsoft Visual Studio 2012
  • Microsoft Visual Studio 2013
  • Microsoft Visual Studio 2015
  • Microsoft Visual Studio 2017
  • Microsoft Visual Studio 2019
  • Microsoft Visual Studio 2022

Supported frameworks

Aspose.OMR for .NET supports the following .NET Frameworks:

  • .NET 5.0

  • .NET Standard 2.0

    • .NET Core 3.1
    • .NET Core 3.0
    • .NET Core 2.2
    • .NET Core 2.1
    • .NET Core 2.0
  • .NET Framework

    • .NET Framework 4.8
    • .NET Framework 4.7.2
    • .NET Framework 4.7
    • .NET Framework 4.6.2
    • .NET Framework 4.6.0
    • .NET Framework 4.5.2
    • .NET Framework 4.5.1
    • .NET Framework 4.5.0
    • .NET Framework 4.0
    • .NET Framework 4.0 Client Profile