System Requirements

Overview

Aspose.Slides for Java does not need Microsoft PowerPoint installed, as Aspose.Slides itself is a Microsoft PowerPoint document creation, conversion, page layout and rendering engine.

Supported Operating Systems

Aspose.Slides for Java supports any 32-bit or 64-bit operating system that runs the Java runtime including, but not limited:

Windows

  • Microsoft Windows 2003 Server ( x64, x86)
  • Microsoft Windows 2008 Server ( x64, x86)
  • Microsoft Windows 2012 Server ( x64, x86)
  • Microsoft Windows 2012 R2 Server ( x64, x86)
  • Microsoft Windows 2016 Server ( x64, x86)
  • Microsoft Windows 2019 Server ( x64, x86)
  • Microsoft Windows Vista ( x64, x86)
  • Microsoft Windows XP ( x64, x86)
  • Microsoft Windows 7 ( x64, x86)
  • Microsoft Windows 8, 8.1 ( x64, x86)
  • Microsoft Windows 10 ( x64, x86)

 

Linux

  • Linux (Ubuntu, OpenSUSE, CentOS and others)

Mac

  • Mac OS X

Supported Java Versions

Aspose.Slides for Java supports the following Java versions:

  • J2SE 6.0 (1.6)
  • J2SE 7.0 (1.7)
  • J2SE 8.0 (1.8)
  • JDK9
  • JDK10
  • JDK11