System Requirements

Supported Operating Systems

Aspose.OCR for C++ is a native library. Aspose.OCR for C++ supports 64-bit operating systems

Development Environments

You can use Aspose.OCR for C++ to develop applications in any development environment that supports C++

WINDOWS

Dependencies CPU version

  • Microsoft.ML.OnnxRuntime.1.7.0

Notice: if you install a package from Nuget, you don’t need to install any additionals. If you simply want to use Aspose.Ocr.dll, you will need to:

  • add a reference on Aspose.Ocr.dll

  • install from Nuget Microsoft.ML.OnnxRuntime Version="1.7.0”

Dependencies GPU version

  • Microsoft.ML.OnnxRuntime.Gpu.1.4.0

GPU version

If you want to use Aspose.Ocr.Cpp-GPU you have to make sure does your GPU supports CUDA. You can do this by link https://developer.nvidia.com/cuda-gpus. To use CUDA on your system, you will need the following installed:

Installation guide for CUDA you can find by link [CUDA install] (https://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html)