Comment exécuter les exemples
Télécharger Aspose.Slides depuis GitHub
Tous les exemples d’Aspose.Slides pour Java sont hébergés sur GitHub. Vous pouvez soit cloner le dépôt à l’aide de votre client GitHub préféré, soit télécharger le fichier ZIP depuis ici.
Extrayez le contenu du fichier ZIP dans n’importe quel dossier de votre ordinateur. Tous les exemples se trouvent dans le dossier Examples.

Importer les exemples dans l’IDE
Le projet utilise le système de construction Maven. Tout IDE moderne peut facilement ouvrir ou importer le projet et ses dépendances. Ci-dessous, nous vous montrons comment utiliser les IDE populaires pour compiler et exécuter les exemples.
IntelliJ IDEA
Cliquez sur le menu File et choisissez Open. Parcourez le dossier du projet et sélectionnez le fichier pom.xml.

Le projet s’ouvrira et téléchargera les dépendances automatiquement. Depuis l’onglet Project, parcourez les exemples dans le dossier src/main/java. Pour exécuter un exemple, faites simplement un clic droit sur le fichier et choisissez “Run ..”, l’exemple sera exécuté et la sortie sera affichée dans la fenêtre de console intégrée.

Eclipse
Cliquez sur le menu File et choisissez Import. Sélectionnez Maven - Existing Maven Projects.

Parcourez le dossier que vous avez cloné ou téléchargé depuis GitHub et sélectionnez le fichier pom.xml. Le projet s’ouvrira et téléchargera les dépendances automatiquement. Depuis l’onglet Package Explorer, parcourez les exemples dans le dossier src/main/java. Pour exécuter un exemple, faites simplement un clic droit sur le fichier et choisissez Run As - Java Application, l’exemple sera exécuté et la sortie sera affichée dans la fenêtre de console intégrée.

NetBeans
Cliquez sur le menu File et choisissez Open Project. Parcourez le dossier que vous avez cloné ou téléchargé depuis GitHub. L’icône du dossier Examples indiquera qu’il s’agit d’un projet Maven. Sélectionnez Examples et ouvrez-le.

Le projet s’ouvrira et téléchargera les dépendances automatiquement. Depuis l’onglet Projects, parcourez les exemples dans source packages. Pour exécuter un exemple, faites simplement un clic droit sur le fichier et choisissez Run File, l’exemple sera exécuté et la sortie sera affichée dans la fenêtre de console intégrée.

Ajouter la bibliothèque Aspose.Slides dans le référentiel local Maven
Lorsque vous importez le projet Aspose.Slides Examples dans l’IDE, Maven télécharge automatiquement le fichier JAR aspose.slides depuis le Aspose Maven Repository. Si vous n’avez pas accès à Internet, vous pouvez ajouter manuellement le JAR à votre référentiel local.
mvn install
Téléchargez le aspose.slides, extrayez-le et copiez le fichier aspose.slides-version.jar ailleurs, par exemple sur le lecteur C. Exécutez la commande suivante :
mvn install:install-file
- Dfile=c:\aspose.slides-version.jar
- DgroupId=com.aspose
- DartifactId=aspose-slides
- Dversion={version}
- Dpackaging=jar
Désormais, le JAR aspose.slides est copié dans votre référentiel local Maven.
pom.xml
Après l’installation, il suffit de déclarer la coordonnée aspose.slides dans le pom.xml. Ajoutez le référentiel suivant dans l’onglet repositories et la dépendance dans l’onglet dependencies.
<repository>
<id>AsposeJavaAPI</id>
<name>Aspose Java API</name>
<url>https://releases.aspose.com/java/repo/</url>
</repository>
<dependency>
<groupId>com.aspose</groupId>
<artifactId>aspose-slides</artifactId>
<version>26.10</version>
<classifier>jdk8</classifier>
</dependency>
Terminé
Compilez-le, maintenant le JAR aspose.slides peut être récupéré depuis votre référentiel local Maven.
Contribuer
Si vous souhaitez ajouter ou améliorer un exemple, nous vous encourageons à contribuer au projet. Tous les exemples et projets de démonstration dans ce dépôt sont open source et peuvent être librement utilisés dans vos propres applications.
Pour contribuer, vous pouvez forker le dépôt, modifier le code source et soumettre une Pull Request. Nous examinerons les modifications et les intégrerons au dépôt si elles sont utiles.