Come eseguire gli esempi

Scarica Aspose.Slides da GitHub

Tutti gli esempi di Aspose.Slides per Java sono ospitati su GitHub. Puoi clonare il repository con il tuo client GitHub preferito oppure scaricare il file ZIP da qui.

Estrai il contenuto del file ZIP in una qualsiasi cartella del tuo computer. Tutti gli esempi si trovano nella cartella Examples.

todo:image_alt_text

Importa gli esempi nell’IDE

Il progetto utilizza il sistema di build Maven. Qualsiasi IDE moderno può aprire o importare facilmente il progetto e le sue dipendenze. Di seguito mostriamo come utilizzare gli IDE più diffusi per compilare ed eseguire gli esempi.

IntelliJ IDEA

Fai clic sul menu File e scegli Open. Naviga alla cartella del progetto e seleziona il file pom.xml.

todo:image_alt_text

Il progetto verrà aperto e le dipendenze scaricate automaticamente. Nella scheda Project, sfoglia gli esempi nella cartella src/main/java. Per eseguire un esempio, fai clic destro sul file e scegli “Run ..”, l’esempio verrà eseguito e l’output verrà mostrato nella finestra della console integrata.

todo:image_alt_text

Eclipse

Fai clic sul menu File e scegli Import. Seleziona Maven - Existing Maven Projects.

todo:image_alt_text

Naviga alla cartella che hai clonato o scaricato da GitHub e seleziona il file pom.xml. Il progetto verrà aperto e le dipendenze scaricate automaticamente. Nella scheda Package Explorer, sfoglia gli esempi nella cartella src/main/java. Per eseguire un esempio, fai clic destro sul file e scegli Run As - Java Application, l’esempio verrà eseguito e l’output verrà mostrato nella finestra della console integrata.

todo:image_alt_text

NetBeans

Fai clic sul menu File e scegli Open Project. Naviga alla cartella che hai clonato o scaricato da GitHub. L’icona della cartella Examples indicherà che si tratta di un progetto Maven. Seleziona Examples e aprilo.

todo:image_alt_text

Il progetto verrà aperto e le dipendenze scaricate automaticamente. Nella scheda Projects, sfoglia gli esempi in source packages. Per eseguire un esempio, fai clic destro sul file e scegli Run File, l’esempio verrà eseguito e l’output verrà mostrato nella finestra della console integrata.

todo:image_alt_text

Aggiungi la libreria Aspose.Slides al repository locale Maven

Quando importi il progetto Aspose.Slides Examples nell’IDE, Maven scarica automaticamente il file JAR aspose.slides dal Aspose Maven Repository. Nel caso in cui non avessi accesso a Internet, puoi aggiungere manualmente il JAR al tuo repository locale.

mvn install

Scarica l'aspose.slides, estrailo e copia il file aspose.slides-version.jar in un percorso a tua scelta, ad esempio nell’unità C. Esegui il comando seguente:

mvn install:install-file
    - Dfile=c:\aspose.slides-version.jar
    - DgroupId=com.aspose
    - DartifactId=aspose-slides
    - Dversion={version}
    - Dpackaging=jar

Ora il JAR aspose.slides è copiato nel tuo repository locale Maven.

pom.xml

Dopo l’installazione, dichiara semplicemente le coordinate aspose.slides in pom.xml. Aggiungi il repository seguente nella scheda repositories e la dipendenza nella scheda dependencies.

<repository>
    <id>AsposeJavaAPI</id>
    <name>Aspose Java API</name>
    <url>https://releases.aspose.com/java/repo/</url>
</repository>

<dependency>
    <groupId>com.aspose</groupId>
    <artifactId>aspose-slides</artifactId>
    <version>26.10</version>
    <classifier>jdk8</classifier>
</dependency>

Done

Compila il progetto; ora il JAR aspose.slides può essere recuperato dal tuo repository locale Maven.

Contribuisci

Se desideri aggiungere o migliorare un esempio, ti invitiamo a contribuire al progetto. Tutti gli esempi e i progetti dimostrativi in questo repository sono open source e possono essere utilizzati liberamente nelle tue proprie applicazioni.

Per contribuire, puoi fare fork del repository, modificare il codice sorgente e inviare una Pull Request. Revisioneremo le modifiche e le includeremo nel repository se ritenute utili.