Como Executar Exemplos

Baixar Aspose.Slides do GitHub

Todos os exemplos do Aspose.Slides for Java estão hospedados no Github. Você pode clonar o repositório usando seu cliente favorito do Github ou baixar o arquivo ZIP de aqui.

Extraia o conteúdo do arquivo ZIP para qualquer pasta em seu computador. Todos os exemplos estão localizados na pasta Examples.

todo:image_alt_text

Importar Exemplos na IDE

O projeto usa o sistema de construção Maven. Qualquer IDE moderna pode abrir ou importar facilmente o projeto e suas dependências. Abaixo mostramos como usar IDEs populares para compilar e executar os exemplos.

IntelliJ IDEA

Clique no menu File e escolha Open. Navegue até a pasta do projeto e selecione o arquivo pom.xml.

todo:image_alt_text

Ele abrirá o projeto e baixará as dependências automaticamente. Na aba Project, navegue pelos exemplos na pasta src/main/java. Para executar um exemplo, basta clicar com o botão direito no arquivo e escolher “Run ..”, o exemplo será executado e a saída será exibida na janela de console incorporada.

todo:image_alt_text

Eclipse

Clique no menu File e escolha Import. Selecione Maven - Existing Maven Projects.

todo:image_alt_text

Navegue até a pasta que você clonou ou baixou do GitHub e selecione o arquivo pom.xml. Ele abrirá o projeto e baixará as dependências automaticamente. Na aba Package Explorer, navegue pelos exemplos na pasta src/main/java. Para executar um exemplo, basta clicar com o botão direito no arquivo e escolher Run As - Java Application, o exemplo será executado e a saída será exibida na janela de console incorporada.

todo:image_alt_text

NetBeans

Clique no menu File e escolha Open Project. Navegue até a pasta que você clonou ou baixou do GitHub. O ícone da pasta Examples mostrará que é um projeto Maven. Selecione Examples e abra-o.

todo:image_alt_text

Ele abrirá o projeto e baixará as dependências automaticamente. Na aba Projects, navegue pelos exemplos em source packages. Para executar um exemplo, basta clicar com o botão direito no arquivo e escolher Run File, o exemplo será executado e a saída será exibida na janela de console incorporada.

todo:image_alt_text

Adicionar Biblioteca Aspose.Slides ao Repositório Local Maven

Ao importar o projeto Aspose.Slides Examples na IDE, o Maven baixa automaticamente o arquivo JAR aspose.slides do Aspose Maven Repository. Caso você não tenha acesso à internet, pode adicionar o JAR manualmente ao seu repositório local.

mvn install

Baixe o aspose.slides, extraia-o e copie o arquivo aspose.slides‑version.jar para outro local, por exemplo, a unidade C. Execute o seguinte comando:

mvn install:install-file
    - Dfile=c:\aspose.slides-version.jar
    - DgroupId=com.aspose
    - DartifactId=aspose-slides
    - Dversion={version}
    - Dpackaging=jar

Agora, o JAR aspose.slides está copiado para o seu repositório local Maven.

pom.xml

Após a instalação, basta declarar a coordenada aspose.slides no pom.xml. Adicione o repositório a seguir na aba repositories e a dependência na aba dependencies.

<repository>
    <id>AsposeJavaAPI</id>
    <name>Aspose Java API</name>
    <url>https://releases.aspose.com/java/repo/</url>
</repository>

<dependency>
    <groupId>com.aspose</groupId>
    <artifactId>aspose-slides</artifactId>
    <version>26.10</version>
    <classifier>jdk8</classifier>
</dependency>

Concluído

Compile o projeto, agora o JAR aspose.slides pode ser recuperado do seu repositório local Maven.

Contribuir

Se você deseja adicionar ou melhorar um exemplo, incentivamos a contribuição para o projeto. Todos os exemplos e projetos de demonstração neste repositório são código aberto e podem ser usados livremente em suas próprias aplicações.

Para contribuir, você pode fazer um fork do repositório, editar o código-fonte e enviar um Pull Request. Revisaremos as alterações e as incluiremos no repositório se forem úteis.