Skip to end of metadata
Go to start of metadata

The Aspose.Cells for .NET components do not require Microsoft Excel to be installed either on the client or on the server side.

Contents Summary
  

Supported Operating Systems

Windows

  • Microsoft Windows 2000 ( x64, x86)
  • Microsoft Windows XP ( x64, x86)
  • Microsoft Windows Server 2003 ( x64, x86)
  • Microsoft Windows Server 2008 ( x64, x86)
  • Microsoft Windows Server 2012 ( x64, x86)
  • Microsoft Windows Vista ( x64, x86)
  • Microsoft Windows 7 ( x64, x86)
  • Microsoft Windows 8 ( x64, x86)
  • Microsoft Windows 10 ( x64, x86)
  • Windows Azure

Linux

  • Linux (Ubuntu, openSUSE, CentOS and others)

Mac

  • Mac OS X etc.

.NET Framework versions supported

Aspose.Cells for .NET supports .NET and Mono frameworks as follows:

.NET Frameworks

  • .NET Framework 2.0
  • .NET Framework 3.0
  • .NET Framework 3.5
  • .NET Framework 4.0
  • .NET Framework 4.5
  • .NET Framework 4.5.1
  • .NET Framework 4.5.2
  • .NET Framework 4.6
  • .NET Framework 4.6.1
  • .NET Framework 4.6.2
  • .NET Framework 4.7.1
  • .NET Framework 4.7.2
  • .NET Standard 2.0 (.NET Core 2.0/2.1).

Mono Framework

  • Mono 1.2 or newer.

Development Environments

You can use Aspose.Cells for .NET to develop applications in any development environment that targets the .NET platform, but the following environments are explicitly supported:

  • Microsoft Visual Studio 2005
  • Microsoft Visual Studio 2008
  • Microsoft Visual Studio 2010
  • Microsoft Visual Studio 2012
  • Microsoft Visual Studio 2013
  • Microsoft Visual Studio 2015
  • Microsoft Visual Studio 2017
  • Microsoft Visual Studio 2019

To use Aspose.Cells, the machine doesn't need to have Microsoft Excel installed for the library itself is a spreadsheet management engine. However, to view the excel file generated by the component, you need to have at least Microsoft Excel Viewer installed on your machine.

Aspose.Cells Grid Suite System Requirements

The Aspose.Cells Grid Suite is composed of two controls:

  • Aspose.Cells.GridDesktop
  • Aspose.Cells.GridWeb

The system requirements of both controls are described separately.

To use these two controls, the machine to run Aspose.Cells.GridDesktop and Aspose.Cells.GridWeb doesn't need to have Microsoft Excel installed as Aspose.Cells.GridDesktop and Aspose.Cells.GridWeb can open and save Excel spreadsheets without any need for Microsoft Excel.

Aspose.Cells.GridDesktop

.NET Framework

  • .NET Framework 2.0
  • .NET Framework 3.0
  • .NET Framework 3.5
  • .NET Framework 4.0
  • .NET Framework 4.5
  • .NET Framework 4.5.1
  • .NET Framework 4.5.2
  • .NET Framework 4.6
  • .NET Framework 4.6.1
  • .NET Framework 4.6.2
  • .NET Framework 4.7.1
  • .NET Framework 4.7.2

Development Tools

  • Microsoft Visual Studio 2005
  • Microsoft Visual Studio 2008
  • Microsoft Visual Studio 2010
  • Microsoft Visual Studio 2012
  • Microsoft Visual Studio 2013
  • Microsoft Visual Studio 2015
  • Microsoft Visual Studio 2017
  • Microsoft Visual Studio 2019

Operating System

  • Microsoft Windows 2000
  • Microsoft Windows XP
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2012
  • Microsoft Windows Vista
  • Microsoft Windows 7, 
  • Microsoft Windows 8, 8.1
  • Microsoft Windows 10

Aspose.Cells.GridWeb

.NET Framework

  • .NET Framework 2.0
  • .NET Framework 3.0
  • .NET Framework 3.5
  • .NET Framework 4.0
  • .NET Framework 4.5
  • .NET Framework 4.5.1
  • .NET Framework 4.5.2
  • .NET Framework 4.6
  • .NET Framework 4.6.1
  • .NET Framework 4.6.2
  • .NET Framework 4.7.1
  • .NET Framework 4.7.2

Development Tools

  • Microsoft Visual Studio 2005
  • Microsoft Visual Studio 2008
  • Microsoft Visual Studio 2010
  • Microsoft Visual Studio 2012
  • Microsoft Visual Studio 2013
  • Microsoft Visual Studio 2015
  • Microsoft Visual Studio 2017
  • Microsoft Visual Studio 2019

Internet Information Server (IIS)

  • IIS 5.0 or above

Browsers

  • IE 5.5 or above
  • Mozilla Browsers (including Firefox, Netscape Browser, etc.)
  • Opera (Internet Explorer 6.0 recommended)
  • Google Chrome

Operating System

  • Microsoft Windows 2000
  • Microsoft Windows XP
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2012
  • Microsoft Windows Vista
  • Microsoft Windows 7, 
  • Microsoft Windows 8, 8.1
  • Microsoft Windows 10
Labels
  • No labels